
GO-CR Index

The Index contains a list of all Help topics available for GO-CR. Index items are arranged in alphabetical 
order within each major category. You can use the scroll bar to see the entries that are not currently 
visible in the Help window.

For information on how to use Help, press F1 or choose Using Help from the Help menu.

Keyboard

GO-CR keys

Commands

File Menu
Edit Menu
Recognize Menu
Prescan Menu
Show Menu
Options Menu

Procedures
Appending text to an existing file
Changing GO-CR's working parameters
Changing the type of the hand scanner
Checking the scanner's switches and document quality
Copying image (bitmap) onto Clipboard
Copying, Cutting, and Pasting text
Deleting text
Deleting the actual text and/or image
Displaying the recently recognized text
Displaying the recently scanned image at different scales
Merging texts or putting texts together
Recognizing a part of the recently scanned image
Recognizing from the recently scanned image
Recognizing from scanner
Saving a part of the scanned image
Saving the resulting image of a 'Prescan' or 'Recognition'
Saving the resulting text of a Recognition
Scanning an image
Scanning/recognizing multi-column texts/images
Selecting all the Text
Selecting a part of the scanned image
Selecting column handling options
Selecting the image processing attribute
Selecting the output character set
Selecting the scanning direction
Selecting the merging option
Showing/hiding the Action/Option tools
Undoing edits
Using the Action/Option tools



GO-CR keys

Use the following keys in GO-CR:

____________________________________________________________________________________
______________________________

In Window with Recognized Text:

Moving the Insertion Point
Key(s) Function

Up Arrow Moves up one line.
Down Arrow Moves down one line.
Right Arrow Moves right one character.
Left Arrow Moves left one character.
Ctrl+Right Arrow Moves right one word.
Ctrl+Left Arrow Moves left one word.
Home Moves to the beginning of the line.
End Moves to the end of the line.
PgUp Moves up one window.
PgDn Moves to the beginning of the document.
Ctrl+End Moves to the end of the document.

Selecting Text
Key(s) Function

Shift+Left or Right Arrow Selects text one character at a time to the left or right or, if
the character is already selected, cancels the selection.

Shift+Down or Up Selects one line of text up or down or, if the line is already
selected, cancels the selection.

Shift+PgUp Selects text up one window. Or, if the previous window is 
already selected, cancels the selection.

Shift+PgDn Selects text down one window. or, if the next window is 
already select, cancels the selection.

Shift+Home Selects text to the beginning of the line.
Shift+End Selects text to the end of the line.
Ctrl+Shift+Left Arrow Selects the previous word.
Ctrl+Shift+Right Arrow Selects the next word.
Ctrl+Shift+Home Selects text to the beginning of the document.
Ctrl+Shift+End Selects text to the end of the document.
Ctrl+Ins Copies the selected text onto Clipboard

In window with scanned image
Key(s) Function

Arrows Scrolls the image in the arrow's direction
Space+arrows Draws a frame into the image to mark an area for 

subsequent recognition



Commands

File Menu

New
Save
Save As...
Save Image Selection...

Edit Menu

Undo
Cut
Copy
Paste

Select All

Recognize Menu

Read From Scanner
Read Last Bitmap

Prescan Menu

Scale

Show Menu

Last Text
Last Bitmap, Scale

Options Menu

Parameters...
Control
Tools



File Menu

New
Save
Save As...
Save Image Selection...



Edit Menu

Undo
Cut
Copy
Paste
Clear
Select All



Recognition Menu

Read From Scanner
Read Last Bitmap



Prescan Menu

Scale



Show Menu

Last Text
Last Bitmap, Scale



Options Menu

Parameters...
Control
Tools



Recognizing from scanner

To recognize text from the scanner:

1 Set parameters in the Options menu if necessary.

2 From menu: choose 'Read from Scanner' from the Recognize menu.

By graphic tools: click on this tool on the left side of the window.

3 Move the scanner carefully in the selected direction over the text to be recognized.

4 Hit any key to stop the scanning process. The recognition process begins and the text appears on the 
screen.

Notes

1 If the scanner's light goes off before the desired part is scanned the available memory buffer is full. In this case using the text 
merging option is recommended.

2 The scanned image can be later displayed at different scale values.

Related Topics
Recognizing from the recently scanned image
Recognizing a part of the recently scanned image
Merging texts or putting texts together
Displaying the recently scanned image at different scales.



Recognizing from the recently scanned image

To recognize text from the recently scanned image:

* From menu: choose 'Read from Last Bitmap' from the Recognize menu.

By graphic tools: click on this tool on the left side of the window.

The recognition process begins and the text appears on the screen.

Related Topics
Recognizing from scanner
Recognizing a part of the recently scanned image



Recognizing a part of the recently scanned image

To recognize a part of the recently scanned image:

1 Select the desired part of the image by drawing a bounding frame on it.

2 From menu: choose 'Read Last Bitmap' from the Recognize menu.

By graphic tools: click on the tool on the left side of the window.

The recognition process begins and the text appears on the screen.

Related Topics
Recognizing from scanner
Recognizing from the recently scanned image
Selecting a part of the scanned image.



Scanning an image

To scan an image:

1 Set parameters in the Options menu if necessary.

2 From menu: choose 'Scale' from the Prescan menu and choose the desired scale value for 
displaying the image (100%, 50%, 25%) from Scale's submenu.

By graphic tools: see below.

Click on this tool to display the    image without compression after scanning.

Click on this tool to display the image at 50% compression after scanning.

Click on this tool to display the image compressed to 25% of its original size after 
scanning

After selecting the scale of displaying click on this tool to start scanning.

3 Move the scanner carefully over the document to be scanned.

4 Hit any key to stop the scanning process.

Notes

* If the scanner's light goes off before the desired part is scanned the available memory buffer is full.

Related Topics
Displaying the recently scanned image at different scales



Displaying the recently scanned image at different scales

To display the recently scanned image:

1 From menu: choose 'Last Bitmap, Scale' from the Show menu and choose the necessary scale 
value for displaying the image (100%, 50%, 25%) from 'Last Bitmap, Scale''s submenu.

By the graphic tools: see below.

Click on this tool to display the    image without compression.

Click on this tool to display the image at 50% compression.

Click on this tool to display the image compressed to 25% of its original size
2 If using graphic tools and the window currently contains recognized text one additional step is 

required: 

Click on this tool to display at the selected scale value
Notes

* This procedure can be carried out after recognizing from scanner too. It is not necessary to make a prescan first to get a bitmap 
of the scanned image.

Related Topics
Scanning an image
Recognizing from scanner



Displaying the recently recognized text

To display the recently recognized text:

* From menu: choose 'Last Text' from the Show menu.

By the graphic tools: click on this tool on the left side of the window.

Notes

* This procedure can be used if the recently scanned image is displayed after recognition.

Related Topics
Displaying the recently scanned image at different scales.
Recognizing from scanner



Saving the resulting text of a Recognition

To save the recognized text under a new name:

1 Choose 'Save As...' from the File menu.

2 Enter a new filename or select an existing one from the listbox.

3 Select the Save button in the dialog box

To save the current text after subsequent changes:

* Choose 'Save' from the File menu.

Notes

* The text is saved in ASCII format, characters are represented in the output character set that was selected at recognition time.

Related Topics
Appending text to an existing file



Saving the resulting image of a Prescan or a Recognition

To save the the image under a new name:

1 Choose 'Save As...' from the File menu.

2 Enter a new filename or select an existing one from the listbox.

3 Checkmark the compressed checkbox to create a compressed TIFF (PackBits) file or remove the 
checkmark to create an uncompressed TIFF file.

4 Select the save button in the dialog box

To save the scanned image under the current name:

* Choose 'Save' from the File menu.

Notes

1 An image can be saved only if it is currently displayed in GO-CR's window, i.e. after 'Prescan' or 'Show Last Bitmap'.

2 The scanned image is saved in it's original size regardless of the current scaling factor.

Related Topics
Saving a part of the scanned image
Scanning an image
Displaying the recently scanned image at different scales



Saving a part of the scanned image

To save a part of the scanned image:

1 Select a part of the image.

2 Choose 'Save Image Selection...' from the File menu.

3 Enter a new filename or select an existing one from the listbox.

4 Set the compressed flag to checked to create a compressed (PackBits) TIFF file or set it to 
unchecked to create an uncompressed TIFF file.

5 Select the save button in the dialog box

To save the image selection under the current name:

* Choose 'Save' from the File menu.

Notes

1 An image selection can be saved only if it is currently displayed in GO-CR's window, i.e. after 'Prescan' or 'Show Last Bitmap'.

2 The selected part is saved in it's original size regardless of the current scaling factor.

Related Topics
Saving the resulting image of a 'Prescan' or a 'Recognize'
Scanning an image
Displaying the recently scanned image at different scales.



Appending text to an existing text file

To append text:

1 Choose 'Save As...' from the File menu.

2 Select an existing file name from the listbox.

3 Checkmark the append checkbox in the dialog box.

4 Select the save button in the dialog box.

Notes

* The text is saved in ASCII format, characters are represented in the output character set that was selected at recognition time.

Related Topics
Saving the resulting text of a recognition



Deleting the actual text and/or image

To delete the actual text and/or image:

* Choose 'New' from the File menu.

Notes

* If there is text and/or image not yet saved the program gives the opportunity to save it before completing this command.

Related Topics
Saving the resulting text of a Recognition.
Saving the resulting image of a Prescan or Recognition



Changing GO-CR's working parameters

To change GO-CR's parameters from menu:

1 Choose 'Parameters...' from the Options menu.

2 Set the necessary options in the dialog box or select the defaults button.

3 Select the OK button to confirm the new options or cancel to abandon changes.

To change GO-CR's parameters by graphic tools:

* Select the necessary option tool at the bottom of GO-CR's window by clicking on it with the mouse. 
Not all the parameters can be changed with the option tools.

Related Topics
Using Action/Option tools



Selecting the output character set

To select the output character set:

1 Choose 'Parameters...' from the Options menu.

2 Select one of the character sets in the dialog box. The following sets are available : IBM ASCII, 
ANSI,Roman 8.

3 Select OK to set the new character set.

Notes

1 This parameter cannot be changed by the graphic tools.

2 To select the appropriate output character set the user must know how the text will be processed later.

Related Topics
Saving the resulting text of a recognition



Selecting the scanning direction

To select the scanning direction from menu:

1 Choose 'Parameters...' from the Options menu.

2 Select one of the scanning directions in the dialog box. The following directions can be selected: 
Vertical (top to bottom) and horizontal (left to right and right to left).

3 Select OK to set the new scanning direction.

To select the scanning direction by grapic tools:

* Click on the or

or

tool at the bottom of the window depending on the scanning direction.

Notes

* Column handling options are valid only with vertical scanning direction.

Related Topics
Scanning/recognizing multi-column texts/images



Selecting the image processing attribute

To select image attributes from menu:

1 Choose 'Parameters...' from the Options menu.

2 Select one of the image attributes in the dialog box. The following attributes are available: Normal, 
Negative and Contour.

3 Select 'OK' to set the new image attribute.

To select an image attribute by graphic tools:

* Click on one of the following image attribute tools at the bottom of the window:

Normal

Negative

Contour

Notes

* Select 'Normal' to recognize black letters on white background or to scan an image as it is on the original.

* Select 'Negative' to recognize white letters on black background or to invert the scanned image.

* Select 'Contour' to have the objects in the image outlined. (This option cannot be used with 'Recognition').



Selecting column handling options

To select column options from menu:

1 Choose 'Parameters...' from the Options menu.

2 Select one of the column options in the dialog box. The following options can be selected: No 
columns, discard left, discard right, discard both and/or decolumnize.

3 Select OK to set the new column options.

To select column options by grapic tools:

* Click on one of the following column handling tools at the bottom of the window:

no columns or

discard left or

discard right or

discard both and

decolumnize
Important notes

1 See the related topic to have detailed information on column handling.

2 Column handling options are valid only with vertical scanning direction.

Related Topics
Scanning/recognizing multi-column texts/images



Selecting the merging option

To set the merging option from menu:

1 Choose 'Parameters...' from the Options menu.

2 Checkmark the merge texts checkbox.

3 Select OK to set the new option.

To select the merge option by grapic tools:

* Click on this tool at the bottom of the window.

Important notes

1 See the related topic to have detailed information on text merging.

Related Topics
Merging texts or putting texts together



Merging texts or putting texts together

1 Select the merge texts option.

2 Start recognition from scanner and scan the text. Because merge texts is selected this starts a series 
of successive recognitions.

3 Stop the scanning process as described at the corresponding procedure. The recognition begins and 
the recognized text appears on the screen.

4 A dialog box pops up with two buttons: stop and continue.

5 Choose continue to do more scanning and recognition, or stop to finish this series of recognitions.

6 If continue is chosen the scanner is switched on again and the scanning can be continued. After 
scanning go to step 3.

Important notes

The results of the recognitions are put together in the following way:

1. If there are overlapping text parts between two adjacent recognition passes the two parts are merged together in a way that the 
overlapping is eliminated. Always the second set is kept from the two sets of the common lines.

2. If there is no overlapping the second part is simply appended to the preceeding one.

3. The overlapping lines do not have to be exactly the same. The merging algorythm tolerates some differences between the 
corresponding lines.

4.Merge texts is allowed both in vertical or horizontal scanning direction. This option is extremely useful when recognizing text 
without columns with lines longer than the scanning width. In this case scan the text horizontally with the Merge texts option 
set.

Related Topics
Selecting the merging option



Scanning/recognizing multi-column texts/images

1 Select the necessary column handling option.

2 Select vertical scanning direction.

3 Do Recognition (Read)/Prescan from the scanner. If doing Recognition optionally set the merge texts 
option.

4 After scanning the columns are processed according to the selected options.

Important notes

The columns are processed in the following way:

1. Discard left: the first whole or fractional column on the left side is discarded, the rest of the image remains intact.

2. Discard right: the first whole or fractional column on the right side is discarded, the rest of the image remains intact.

3. Discard both: the two whole or fractional columns on the left and right sides are discarded, the rest of the image is processed 
according to the Decolumnize option, i.e. if Decolumnize is not set, the rest of the image remains intact. If Decolumnize is set,
the columns are arranged one below the other. Decolumnizing is successful only if the columns which remain in the image after 
discarding are approximately of the same width.

4. If there is one whole and one fractional column in the scanned image (e.g. at any side of a newspaper or magazine) then 
DISCARD (fractional column's side) and DISCARD BOTH settings give the same result.

Related Topics
Recognizing from scanner
Selecting column handling options
Selecting the scanning direction



Checking the scanner's switches and document quality

To check the scanner and the document:

1 Set the letter/text/photo switch (if there is one) to the letter(text) position (marked usually with a black
square) to get a line-art image. Only line-art images are suitable for recognition.

2 Set the resolution switch to 200, 300 or 400 dpi.

3 Scan the document at 100% displaying scale to get an image on the screen.

4 Check the image on screen. The settings are adequate if the characters are not fragmented and do 
not touch each other.

5 If necessary correct the Brightness and go to step 3.

Related Topics
Scanning an image



Copying, Cutting and Pasting text

To copy and paste or cut and paste text:

1 Select the text.

2 Choose 'Copy' from the Edit menu to copy text or choose 'Cut' to cut text.

3 Move the insertion point where you want the text to appear or select text you want to replace.

4 Choose 'Paste' from the Edit menu.

Related Topics
Deleting text
Selecting all the text
Undoing edits



Deleting text

To delete one character at a time:

1 Press Backspace to delete the character to the left of the insertion point.

2 Press Delete to delete the character to the right of the insertion point.

To delete more than one character:

1 Select the text you want to delete.

2 Press Backspace or Delete, or choose 'Cut' from the Edit menu to place the text onto Clipboard, or 
choose 'Delete' to delete the text, but leave the Clipboard contents intact.

Related Topics
Copying, Cutting and Pasting text
Selecting all the text
Undoing edits



Selecting all the text

To select all the text:

* Choose 'Select All' from the Edit menu.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Undoing edits



Undoing edits

To undo the last edit:

* Choose 'Undo' from the Edit menu.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text



Copying image (bitmap) onto Clipboard

To copy a part of the scanned image onto Clipboard:

1 Scan an image or show the recently scanned one.

2 Select a part of the image.

3 Choose 'Copy' from the Edit menu

Related Topics
Scanning an image
Displaying the recently scanned image at different scales.
Selecting a part of the scanned image.



Using Action/Option tools

Using the action tools:

The Action Tools appear at the left side of GO-CR's window. Choosing an action can be done by clicking
on it with the mouse. The mouse button must be released while the mouse cursor is in the action tools 
area. If the mouse button is released outside it, the action will not be chosen

The Action Tools are the following ones:

Read from Scanner

Read last Bitmap

Prescan

Show last Text

Show last Bitmap
The Option Tools appear at the bottom of GO-CR's window. Selecting an option can be done by clicking 

on it with the mouse. The actual setting is indicated by a frame on the selected option's image (blue on
color monitors). Options not available at the current settings are dimmed. Column handling tools are 
flashing while the program processes columns.The 50% and 25% 'Scale' tools are flashing while the 
scanned image is being scrolled and disk transfer occurs.

The Option Tools (scanning direction):

top to bottom,

left to right,

right to left
The Option Tools (column handling):

no columns, 

discard left,

discard right,

discard both

merge texts, 

decolumnize



The Option Tools (image display scaling):

no compression, 

compress to 50%, 

compress to 25%
The Option Tools (image attributes):

normal image

negative (invert) image,

outline image
Notes

* All functions are available without graphic tools.

Related Topics
Showing/hiding the Action/Option tools
Changing GO-CR's working parameters



Showing/hiding the Action/Option tools

To show tools (if not showed):

* Choose 'Tools' from the Options menu.

To hide tools (if showed):

* Choose 'Tools' from the Options menu.

Related Topics
Using Action/Option tools



Selecting a part of the scanned Image

With mouse:

1 Click with the mouse to any corner of the area to be selected and hold down the mouse button.

2 Drag the mouse to the opposite corner of the area with the mouse button still pressed. The selected 
area is marked with a frame drawed with a broken line.

3 The frame can be removed by a simple mouse click.

With keyboard:

1 Position the cursor with the arrow keys to any corner of the area to be selected.

2 Press and hold down the space bar.

3 Use the arrow keys to draw the frame.

4 To remove the frame press spacebar.

Related Topics
Recognizing a part of the recently scanned image
Copying image (bitmap) onto Clipboard



Changing the type of the hand scanner

To select the type of the hand scanner currently used:

1 Choose 'Control' from the Options menu.

2 Select the type of your hand scanner.

3 If DMA buttons are enabled then select the DMA channel you want to use.



Procedures

Recognizing from scanner
Recognizing from the recently scanned image
Recognizing a part of the recently scanned image
Scanning an image
Displaying the recently scanned image at different scales
Displaying the recently recognized text
Saving the resulting text of a recognition
Saving the resulting image of a prescan or recognition
Saving a part of the scanned image
Appending text to an existing file
Deleting the actual text and/or image
Changing GO-CR's working parameters
Selecting the output character set
Selecting the scanning direction
Selecting the image processing attribute
Selecting column handling options
Selecting the merging option
Merging texts or putting texts together
Scanning/recognizing multi-column texts/images
Checking the scanner's switches and document quality
Copying, Cutting, and Pasting texts
Deleting text
Selecting all the text
Undoing edits
Copying image (bitmap) onto Clipboard
Using the Action/Option tools
Showing/hiding the Action/Option tools
Selecting a part of the scanned image
Changing the type of the hand scanner



New

Clears the current working area (removes text and/or image).

Related Topics
Saving the resulting text of a Recognition
Saving the resulting image of a Prescan or a Recognition



Save

Saves the recognized text or scanned image.

Related Topics
Saving the resulting text of a Recognition
Saving the resulting image of a Prescan or a Recognition



Save As...

Saves the recognized text or scanned image under the specified file name.

Related Topics
Saving the resulting text of a Recognition
Saving the resulting image of a Prescan or a Recognition



Save Image Selection

Saves the selected part of the scanned image under the specified file name.

Related Topics
Saving a part of the scanned image



Undo

Undoes the last edit.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits



Cut

Copies the selected text onto Clipboard and removes it from the current text.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits



Copy

Copies the selected text or bitmap onto Clipboard.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits
Copying image (bitmap) onto Clipboard



Paste

Pastes text from the Clipboard.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits



Delete

Deletes the selected text.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits
Copying, Cutting and Pasting texts



Select all

Selects the whole text.

Related Topics
Copying, Cutting and Pasting text
Deleting text
Selecting all the text
Undoing edits



Read from Scanner

Starts the recognition from the scanner.

Related Topics
Recognizing from scanner



Read from Last Bitmap

Starts the recognition from the recently scanned image (bitmap).

Related Topics
Recognizing from the recently scanned image
Recognizing part of the recently scanned image



Prescan from scanner

Starts the scanning from the scanner and displays the resulting image at the selected scale 
value.

Related Topics
Scanning an image
Checking the scanner's switches and document quality



Show last text

Displays the recently recognized text if the corresponding image is displayed.

Related Topics
Displaying the recently recongized text



Show last bitmap

Displays the last bitmap at the selected scale value.

Related Topics
Displaying the recently scanned image at different scales



Parameters

Invokes the pameter setting dialog box.

Related Topics
Changing GO-CR's working parameters



Control

Invokes the dialog box for changing the scanner type.

Related Topics
Changing the type of the hand scanner



Tools

Shows or hides the Action/Option tools.

Related Topics
Showing/hiding tools




